[GENTOO] All ebuilds that could satisfy “package” have been masked

Uno de los sistemas operativos, donde mas me incomoda trabajar después de Windows, es Gentoo, ese Sistema Operativo que tiene muchos adeptos y que sin duda es de los mas engorrosos que existen en el mercado pero que muchos aseguran que ofrece el mejor performance a sus aplicaciones ya que lo compilan desde el primer segundo en que crean la idea de instalarlo en sus cabezas.

Emerge es el manejador de paquetes usado por esta distribución, y que en mi opinión, si muchos critican los RPM de red hat y hasta desean que desaparezca, no se que pensarán de este, pero bueno no todo en la vida es color de rosa y a veces tenemos que trabajar en ambientes que no nos agradan al 100%.

Hoy tuve que instalar Munin en uno de estos equipos y recordar lo que era Gentoo.

Para instalar el Munin-node, el primer detalle a tener en cuenta es que por emerge no hay opción como en otras distros para instalarlo independientemente de munin. Es por esto que debemos instalar el paquete completo y lo que hacemos es que no configuramos ningun nodo dentro de munin. Pero al hacer un emerge en algunos casos nos encontraremos con el Título de este post “All ebuilds that could satisfy “munin” have been masked” con el siguiente error:
Calculating dependencies |
!!! All ebuilds that could satisfy “munin” have been masked.
!!! One of the following masked packages is required to complete your request:
- net-analyzer/munin-1.3.2 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.2-r1 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.2-r2 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.2-r3 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.3 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.3-r1 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.3-r2 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.4 (masked by: ~x86 keyword)
- net-analyzer/munin-1.3.4-r1 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

Solución 1:

Para lo cual debemos seguir lo siguiente:

  1. emerge autounmask
  2. autounmask net-analyzer/munin-1.3.2
  3. emerge munin

Solución alternativa:

Otra solución para este problema es editar el archivo /etc/portage/package.keywords y agregar la siguiente línea:

=net-analyzer/munin-1.3.2 ~x86

Con esto debería funcionar todo. Recuerden que en el caso de Gentoo los plugins no se agregan automáticamente a nuestro directorio /etc/munin/plugins hay que crear los link simbólicos manualmente.

 

 

Wow. It's Quiet Here...

Be the first to start the conversation!

Leave a Reply:

Gravatar Image

XHTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>